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When it comes to choosing file formats for digital publishing, the Adobe® Portable Document Format 
(PDF) is the winner by far. It's essentially paperless, perfectly portable, and equipped with all kinds of 
nifty features. As an industry standard, CorelDRAW® software supports many PDF features, including 
linking capabilities. If you're new to creating Web or bookmark links with CorelDRAW, this tutorial will 
show you how it's done and how to make sure that the links are preserved in your PDF documents.

Discover the Beauty of PDF
The popularity of Adobe® Acrobat® Reader® software makes it possible for anyone to view PDF files. 
For the small business owner, there is nothing better than going totally digital. Not only does paperless 
publishing reduce, or even eliminate, printing costs, but it also presents other opportunities unheard of 
just a decade or so ago.

In most cases, digital documents don't have color, size, or length limitations and can be freely distributed 
across the globe in a matter of seconds. The best part is that you can add interactivity to your portable 
documents and have a certain degree of control over how your audience views your document. The 
nonlinear aspects of interactive documents, such as hyperlinks, demand a little more planning than your 
typical printed document, so the design stage may be more challenging.

Plan Your Document Design
As with any complex project, the planning stage is always the first critical step. If possible, prepare your 
content elements in advance - including the text, graphics, and photos. Decide on a page size and plan 
how you'd like your content to flow. As you add structure to your content, think of how you'd like your 
audience to move through your document.

CorelDRAW enables you to give unique names to pages which the PDF export filter will then use to 
create a PDF bookmark list for easy navigation. When you design a document in CorelDRAW, however, 
you can apply bookmarks to text or graphics to create your own navigation method. When your reader 
clicks text or graphics applied with a bookmark link in Acrobat Reader, their view instantly changes to 
display the corresponding bookmark item.

Consider the opportunities for providing links to Web sites. With CorelDRAW, you can assign URL 
hyperlinks or e-mail addresses to items in your document. Clicking a hyperlink from within the PDF 
document automatically launches the Web application associated with the type of URL, such as mailto, 
file, http, https, gopher, FTP, news, telnet, and so on.

Design a Navigation Method
You can use almost any text or graphic as a navigation device, which typically identifies the current 
location and shows other areas to explore. As an example, I've created a promotional document for a 
fictitious health product company. For the navigation, I've used a folder tab-style design to indicate the 
specific areas in the document (see below).

In CorelDRAW, I've applied links to the tab buttons for page navigation. The example below shows the 
active button area.
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Under each page tab are text objects to which I've applied bookmarks linked to specific text headings on 
the page (see below).

Throughout my fictitious document, I've applied hyperlinks to Web pages that provide the audience with 
current product information. I've also added e-mail addresses to direct readers to specific company 
contacts (see below). In Acrobat Reader, active bookmark links are indicated by a pointing-finger cursor, 
and active hyperlinks are indicated by the same cursor featuring a W (for Web).

Now let's explore how these links are created in CorelDRAW to make your text and objects interactive 
when they are published to PDF.

Create Links in CorelDRAW®

We'll start with bookmarks.

In a PDF file, Acrobat Reader can display page bookmarks in a bookmark list. This list is a basic page 
navigation tool, and it allows your audience to move quickly between document sections. The unique 
name you assign to each page in your document becomes the bookmark page name in Acrobat Reader. 
I've named each page according to the subject areas in my example (see below).

After publishing the document to PDF, the page names appear in the bookmark list when the document is 



viewed in Adobe® Acrobat® (see below). By default, pages are also sequentially numbered. Bookmark 
destinations on the pages are included as subsets.

To name a page in your CorelDRAW document, right-click its page tab at the bottom of your document 
window, and choose Rename Page from the context menu. In the dialog box that opens, you can assign a 
page name up to 31 characters long (see below).

To create a link, you need to define at least one source and link the source to a destination. By doing this, 
you create your own internal document page navigation system: you decide which items to use as the 
sources (such as photos, shapes, or text) and then you link those sources to destination items in your 
document. You can specify the source and destination by using two key features of CorelDRAW- the 
Internet toolbar and the Internet Bookmark Manager docker.

To open the Internet Toolbar, choose Window > Toolbars> Internet. Although this toolbar includes several 
other features, the main areas you'll use are the Behavior selector and the Internet Address/Bookmark 
selector (see below). Using these options, you can build your bookmark list by specifying the bookmark 
destinations (explained later).

The source items are defined by using the Internet Bookmark Manager (choose Window > Dockers > 
Internet Bookmark Manager). The Bookmark Manager (shown below) enables you to view a list of all 
bookmarks that you've applied to items in your document. The Link button enables you to establish a 



bookmark link between your selected item and the bookmark selected in the list. The docker also includes 
a Select button to quickly locate items that are linked to a selected bookmark.

There are two types of bookmarks you can create in CorelDRAW: page bookmarks, which navigate to a 
specific page, and target bookmarks, which navigate to a specific item on a page - either text or a graphic. 
Let's begin by creating a page bookmark:

1. With the Internet Toolbar in view, select an item in your document to act as the source of the page 
bookmark link, and choose URL from the Behavior selector.

2. In the Internet Address/Bookmark selector, you'll see a list of default page bookmarks 
sequentially named "Top Of Page N" (where N is the page number). Choose the destination of the 
page bookmark from the list to create the link (see below). 

As an alternative, you can also apply page bookmarks to items by right-clicking the selected object and 
choosing Internet Links > Top Of Page N from the context menu (see below). After you make your 
selection, the Internet Address/ Bookmark selector will show "_PAGEN" as the destination. When your 
document is exported to PDF, clicking the bookmark link will take you to the page you selected.

The second type of bookmark you can create is a target bookmark. This bookmark type is item-specific, 
meaning you can specify an item as the destination and then link it to other items. To create a target 
bookmark, follow these steps:

1. With the Internet Toolbar and the Internet Bookmark Manager in view, select an item on your 



page to serve as the destination. This is the item that your readers will be directed to when they 
click the bookmark link.

2. In the Internet Toolbar, choose Bookmark from the Behavior selector. Notice that the Internet 
Address/Bookmark selector now displays the words "Internet Bookmark" (see below). 

3. Click in the Internet Address/Bookmark selector (the default text disappears), enter a unique name 
for your bookmark destination, and press Enter. Notice that the newly created bookmark is added 
to the Internet Bookmark Manager docker list. 

Web URLs can also be applied as destinations to items in your document by using the Internet Toolbar. A 
URL can be a variety of types, including a Web site address (http:// or https://), a newsgroup (news://), an 
e-mail address (mailto:), a file path (file://), or an FTP site (ftp://). To apply a URL, follow these steps:

1. Select an item to apply the link, and choose URL from the Behavior selector.

2. To specify a Web page, click in the Internet Address/Bookmark selector, type the Web address, 
and press Enter. The default Web site address prefix "http://" is automatically entered (see below). 

To enter a different type of URL address (such as mailto:), you can follow a similar procedure. The only 
difference is that you must manually enter the complete URL, including the prefix. For example, entering 
"mailto:bob@somewhere.com" creates a URL for an e-mail contact (see below). Press Enter to apply the 
address to your selected item.

For convenience, newly created hyperlinks are automatically added to the Internet Address/Bookmark 
selector list so that you can quickly apply them to other items in your document (see below).

Applying Bookmarks and Hyperlinks to Text
The steps we've covered so far generally describe the steps to apply links to objects selected with the Pick 
Tool. In these cases, the links you create are applied to the object and make the entire object clickable.

With text, however, you may want to apply links to individual words or phrases within a text string, 
instead of to the entire text object. This kind of link can be applied only to paragraph text and only if the 
text is Web-compatible (whether or not your PDF is destined for the Web). To apply a bookmark, 
hyperlink or mailto address to a word or a phrase within a larger string of characters, follow these steps:



1. Using the Pick Tool, select your text object. If you've selected an artistic text object as indicated 
by the Status Bar (see below), choose Text > Convert to Paragraph Text (Ctrl+F8).

2. Once the text is converted, choose Text > Make Text Web Compatible. (This option is also 
available as a button in the Internet Toolbar, as shown below.)

3. To create the link, use the Text Tool (F8) to highlight the specific text characters you want to 
make clickable, and then use the Internet Toolbar to apply the link.

4. To make the text a bookmark destination, choose Bookmark from the Behavior selector, enter a 
bookmark name in the Internet Address/Bookmark selector, and press Enter. To set a text source 
for the link, use the Text Tool again to highlight the source text, click your bookmark in the 
Bookmark Manager docker, and click the Link button. 

To apply a URL or mailto hyperlink to your selected text, choose URL from the Behavior selector, enter 
the Web address or mailto address in the Internet Address/Bookmark selector, and press Enter.

After the link is applied to your text, it appears as a typical Web hyperlink, which by default is underlined 
and blue. You can change the appearance of the hyperlinks in your PDF by choosing Tools > Options, 
navigating to Document > Publish to the Web > Links in the tree directory, and then choosing a color 
from the Link Color area.

Export to PDF from CorelDRAW® 12
When you're ready to publish, choose File > Publish to PDF to open the Save as PDF dialog, and save 
your new portable, interactive document. Before clicking the Save button, you may want to customize 
how your document will be created. Click the Settings button to open the Publish to PDF dialog which 
features options organized into six tabbed areas.

If the PDF you're creating is for screen viewing, be sure to click the Document tab to access the 
bookmark options (see below) and select the Include Hyperlinks and Generate Bookmarks options. 
Choosing Include Hyperlinks will ensure that the URL and bookmark links you've created in your 
document will be interactive in the published PDF.



Choosing Generate Bookmarks will create an Acrobat Reader bookmark list from the page and target 
bookmarks in your document, so the interactivity you've engineered into your document will be included 
in the PDF.

The final step before distributing your published PDF is to examine it carefully and verify the accuracy of 
each bookmark and link. As any seasoned Web designer will tell you, providing poorly organized links 
and faulty navigation is one of the fastest ways to lose your audience's attention.


